BASIC USER TRAINING PROGRAM
Module 2: User Interface and Environment
Objective

Students will be introduced to the files and directories created by iTest on the host computer. They will get familiar with the main elements of the iTest user interface and will become comfortable using it.

Outline

• Help
• Activities View Layout and Navigation
• Views, Perspectives and Customization
• Workspaces
• Projects
• Preferences
• Collaboration
• Editors and Manipulating the Interface
• Lab
• Quiz

HELP

When you first launch iTest, the perspective that you first see is the Activities perspective. We will talk more about the Activities perspective but let me give you a quick overview of what views and perspectives are.

iTest supports several different perspectives. Each perspective is optimized for a different set of iTest tasks. Each perspective includes several sections where you perform tasks, views and editors. Views and editors are sized and arranged to optimize the space on the user interface.

In the Activities perspective, you will see a section for different Activities on the left and a section for Home page on the right. The Home page is there to give you easy access to some useful resources. While you are working on a specific activity from the left section, this area will be filled with an appropriate editor and supporting views.

iTest loads a dynamic home page hosted externally by Fanfare if internet connectivity is found. It regularly fetches the dynamic content from Fanfare site.

You can choose to see the static home page by setting a preference in the iTest menu. Click Window> Preferences. On the Preferences page, click iTest > Activities. By default, the Home page loads from the Fanfare website. Uncheck the box to load a web page that is stored in the iTest installation directory on your local hard disk.
As you notice, on the help page there are three tabs: Welcome, Workflow and Community. Use the quick search box to search the community and look for helpful content on iTest.

The Welcome page sends the welcome message.

The Workflow page gives you an overview of Developing a Test Case. You will learn more about developing the test case when you actually build it using the Develop a Test Case activity.

The Community tab displays current activity on the Fanfare Community. To access the Fanfare Community and other resources available to you as part of the community of iTest users, click the Community tab.
The Fanfare **Community** is an invaluable resource for all iTest users. Fanfare hosts an **online** community that includes iTest discussion **forums**. You can browse the forums to find answers, or create your own account to post questions. On the discussion Forums, you can participate with other users and iTest experts. The community forum does not require subscription, it does not require you to own iTest, and it does not require you to register. There are number of videos available to watch and learn new features.

To access the discussion forum click **Learn more about the Fanfare Community**. As you see the community **forum** page, it is organized by topic.
Click on **General iTest Topics** forum. You can see this as the place where people can come to post their questions. On the other hand, fanfare employees can post the **frequently asked questions** or the **best practices**. People can do search and get help. It is anonymous; anyone can come here, search and read the responses. If you need to post a question, you need to register but you do not need to provide your name. You just need to provide the email address and the user id.

Pay close attention to the **Quick Tip** section down at the bottom of the page. This message will be refreshed dynamically from time to time.

On the main menu, click **Help > Help Contents**. This opens up Fanfare User Guide and as you can see that it is organized by topic. You have the option to use the table of contents or to search by keyword. For example, there is a "chapter" devoted purely to Serial Port sessions in the table of contents, or you could enter the text **serial port** into the **Search text box**.
ACTIVITIES VIEW LAYOUT AND NAVIGATION

The **Activities perspective** makes it easier to perform your most **common** activities. As we mentioned earlier, when the Activities page first opens, the home page offers the quick access to the Fanfare community pages and other options. You can always close the page if you want by clicking the x on the Home page tab –

To reset your perspective and bring your Home page back, you can click the Reset Layout button here.

While you are working on the **specific activity**, this area on the Home page is filled with **appropriate editor** and **supporting views**. The **Activities** view guides you through some of these **tasks efficiently** and shows you only the **essential** views or information you need to accomplish those tasks.
**Activities perspective** is optimized for when you are working through certain very common activities like –

- Connect to the devices
- Build a Topology
- Develop a Test Case
- Review Test Reports
- Manage Workspace

To **navigate** from the specific activity page back to the home page, click the home icon right here on the top. For instance, let us click the **Connect To Device** and you will be in the Connect To Devices **editor** page.

To get back to the **Activities home page** from **Connect to Devices page**, you can click either the Home Icon or click on **Return to Activities** at the bottom.

WORKSPACES

Before we talk about workspaces, just a couple of words about the **iTest architecture**, iTest is built in a framework called **Eclipse**. Eclipse is an open source development framework and if you are familiar with Eclipse then iTest should look familiar to you. "**iTest assets**" mean **iTest files** we are going to created throughout this course (mainly the files that control and describe how iTest interacts with different kinds of devices and applications). There are actually **test case** files, **test reports**, things like that. All iTest files are stored in **XML** format. XML is a **cross-platform** technology and is a relatively lightweight technology. An **XML** file is simply a text file with some **markup**, which make it easy to find information. In terms of sharing assets and using version control on them, XML makes that process seamless because the files are easy to compare, as they are relatively small. It also allows them to be **shared** across the **platforms**— if one person is developing a test in **Windows**, the test can easily be shared with a colleague using **Linux**.

**Workspaces** are essentially the logical **collection** of **projects**. A workspace is nothing more than a local folder
on the file system. In my case, I am doing this course on a Windows computer but it is analogous on a Linux system. To determine your current workspace, look at the title bar of iTest. In the example, we see

iTest Activities – iTest 4.0 C:|iTest_workspace\CBT_workspace

iTest 4.0 is the version that I am currently running and then I have a path to the workspace named CBT_workspace. And if I go ahead and bring up that folder on my file system, you can see that this is just a folder with few ‘dot’ files here that are just preference files called .capture, .metadata, .launch, and .report. You can see that there are two other folders-

- my_project
- resources.

iTest project simply is a project that contains iTest assets. An iTest project is a container for your assets that resides inside your iTest workspace. These are identified as projects because their icon resembles a blue folder (not just a paper manila folder).
When you first start, iTest supplies the folders within the my_project project that you see here. If you open my_project, you can see that the folders inside are just standard folders.

You can save iTest files anywhere you like, but here are the default locations for saving documents:

- capture_reports: When you create a capture report, the system suggests that you save it in the capture_reports folder.
- form_maps: A library of form map documents that identify the actionable targets on Web pages
- response_maps: A library of response map documents that simplify extracting data from a response
- session_profiles: Session configuration settings saved as session profile documents
- test_cases: Executable test cases
- test_suites
- testbeds
- topologies

The resources project is in every iTest workspace and it contains template files and other system files that iTest uses to create some of its reports, views etc.

my_project is an iTest project (identified by the Fanfare logo). You can always double check whether a project is an iTest project by selecting the project, clicking File and selecting Properties. The 'iTest project Natures' property shows that everything except iTest Resources is checked, indicating that it is an iTest project.
Don’t worry too much about what all this means right now but just recognize the fact that these check marks gives us the spiral F which indicate that it is an iTest project.

Here are the steps to create a new project

1. Click the Add button.

2. A New iTest Project dialog box opens. Let’s name this one demo_project and then click Finish.
3. A project is created inside the workspace. It is automatically set as an iTest project as you can tell from the Fanfare icon on the folder.

4. Go to the file system and you can see the project folder has been created here on the file system as well.

That is how you create a project inside your workspace. That gives you an idea of how workspaces and projects relate.

**Switching workspace**

To switch to another workspace:

1. On the main menu, click **File > Switch workspace**.

2. Select the workspace that you have been currently using or you can go to other. If you choose **Other**, you can simply go to **Browse** and as mentioned earlier, workspace is simply a folder on the file system. **Dropdown** shows your recent workspaces or you can just type in the **path** here.

3. If you type in the folder that does not exist then iTest will create the folder and create the workspace in there and switch over to that workspace. At this point, let us stay in this workspace so just select ‘**cancel**’.
iTest Preferences are found in the windows menu and it is the last menu item.

And as you see there are seven categories of iTest preferences on the left hand side and a filter box at the top. Most of the preferences you will be concerned with are under iTest category. There are several preferences under here. We will certainly not go through them now, however ‘help’ does a very good job of describing what all these preferences means. There are a couple of preferences that are actually good to change and we will explain those in the module where they actually apply. Most of them are to do with how we interact with sessions and a couple of other things with regard to test reports. We will get to those when we get to those modules.

COLLABORATION

1. Exporting a project
2. Importing a project
3. Subversion Control
4. Importing the project from a different workspace on the file system
5. Exporting preference settings
6. Sharing Test Reports

**Exporting a project**

The simplest way to share the project is to export the project and have your colleague import the project.

3. Select **demo_project**. Select File > Export
4. Your General folder might not be expanded and might look like this. If it is not expanded, then go ahead and expand it.

5. Select Archive file. Click Next. Your To Archive Field probably will be blank.

What you would want to do is select the demo_project project here and by selecting cbt_project, it will select everything underneath.

6. To archive the file, click Browse. Select Desktop and call it demo_project.zip.

7. Click Save, Click Finish. Now you take that zip file and mail it to colleague, put it on the flash drive and put it up on the company share and one of my colleagues can import it.
Importing a project

Suppose you need to import the `demo_project.zip` file in another workspace on the same system or you hand it over to your colleague, here are the steps to import it into a new workspace on the same system or on your colleague’s system.

1. Open a **new** workspace
2. Go to **File - Import**.
3. Under the General folder, select **Existing folder into workspace**.
4. Select **archive file**. Even though it says archive file, it represents a project. Browse and pick the `demo_project.zip` that you saved above in the folder on your desktop.
5. Click ‘Finish’. You will notice that one project has been imported into the workspace. This project includes all the assets developed by the co-worker and you can use them anytime I want.

**SUBVERSION CONTROL**

Also in the spirit of collaboration, many companies use subversion control and iTest is fully integrated into subversion control. It is easy to connect to your repository. You can go to your SVN Repository perspective. Type in the name of the repository and check out your assets.

However, there is another way to connect to the repository and it is through the **psf** file. A **psf** file is the description of the repository, the assets within the repository and way to connect to the repository. Someone in your organization has to export the workspace into a **project set**. A project set also called **psf**, is a text file that contains a **pointer** to each appropriate **project** in the repository. When you import a project set, the pointers are used to **fetch** the **projects** from the **repository**.

Let us **import** the **.psf file**, which will include three **projects**. Here are the steps to Import Project Set from the repository using .psf file -

1. Download the **cbt40_projectSet.psf** file from the **CBT website** (hi-lighted in yellow saying please download the project file and we will talk about it how to use in module 2). **cbt40_projectSet.psf** includes three projects. These projects will be used in the later modules. Save it on your **desktop**.

2. Click Import, the Import Wizard starts.
2. Select project Set and that stands for project set file.

3. Click **Next**

4. Browse to get your **cbt40_projectSet.psf** file saved on your desktop (the file that we asked you to grab from CBT website – fanfare.rollbook.com).
iTest will connect to the repository in that psf file and bring those assets in.

Three projects are added into your workspace here. They were taken from the repository hosted by Fanfare.

As you see the assets are in your workspace and the cylindrical icons are actually indicating that you are in sync with the repository. Now you can open these files in your workspace and edit them. If you right click the file, you can see a menu item called ‘Team. And this is how I will interact with the repository – check in, check out, commit etc.

The **cbt_project_answers** has all the files that we are going to develop throughout this course broken down by modules. In each individual module you have the test cases that we will develop and answers to the lab.

**cbt_project** is the project with the Response Maps and Reference Session Profiles that you will use to create the sessions and develop the test case. We will talk more about the response maps and Session profiles in the later modules.

**Dependancies_demo_project** will be used in the module 9

---

**Importing the project from a different workspace on the file system**

1. Click Import again - This second option here is to get the project from a different workspace on the file system as a project into the current workspace. This is the way you can actually grab the **project folder** from the **file system**
Exporting the preference files

1. Select File > Export
2. Select Preferences
3. Click Next
4. Check Export All
3. Browse to my desktop and name it as **demo_prefs**. The extension is **.epf**

Exporting the preference file and then you can share it with your team member who can then import it. All the **preferences** and the custom **perspective** you have are contained in this file. You can simply export it and import it wherever you are going to use iTest.

All those preferences are set under the **Windows > Preference** menu, we have not set any but we will as we move forward.
Sharing Test Reports

System saves reports in the `.reports` folder. Because the database is local to the workspace, it makes sharing with team members difficult. As we will cover in later modules, you can share reports by converting into HTML format. However, this can be a problem when reports are bigger than 4 to 5 mega bytes.

Alternatively, you can store iTest test reports in a centralized external database (instead of the built-in database), making it easier to share detailed test report data with team members.

Here are the steps

1. There is an external database preference that shows you which database is connected. Click **Window > Preferences** and search for ‘Database’.
2. There is a **Test Report Database** preference. Check **Use an external database to store test reports**

![Preferences Screenshot](image)

The above screen shot shows the configuration for my MySQL database for iTest. Under Test Reports preference, provide the name of the **external database**, The Database address is **localhost**. Port number is 0. Database name **itestreports** and here are my credentials to connect to the iTest Reports data on my server. To put the settings into effect, re-start iTest

See the **iTest Installation Guide** for detailed instructions on configuring the database server for iTest.
EDITORS

1. Session wizard
2. Topology editor
3. Test Case editor
4. Text editor

Let us talk about some of the other iTest editors; Session wizard, Topology editor and Text editor. Click the Home Icon to get back to the Activities perspective.

As you see the layout if Activities perspective is very simple - normally just one view Activities on the left side of the window and the rest of the area available for the file or session you’re working, also called the Editor area. We automatically take care of opening and closing other editors and views when we are working on a specific activity.

**Session wizard**

Let us click Connect to Devices. On the Connect to Devices activity page, you will find the tools you need to launch sessions to connect to a device under test and review results. This set of tools is a lot like a Putty session and an easy and quick way to interact with devices and see the results.

Notice the empty editor area on the right. On the left, there are two sections. The top section lists the defined and built-in sessions. The Active Sessions pane lists sessions that are running now. Because there is no session running, it says there are no active sessions.
A session is a collection of configuration settings that enables you to talk to the application or device under test interactively. To configure a session using the Session wizard, double-click any of the session types in the list. As you see, it brings up the Session wizard area.

- Alternatively, you could select a session type and click **Start a Session**.
The **Start Session** wizard starts.
In the next module, we will cover more about different types of sessions and how to configure and launch them to start an interactive session with a device.

Let us click Home to get back to the Activities home page.

### Topology editor

The Build a topology page provides quick access to the tools that help you to create and edit topologies. In this view, you will be working on the topology in the Topology editor where you define connection settings with devices, and for other types of iTest documents. We will cover topology in the next module but let me give you a quick overview.

A topology document is a collection of the information that test cases need to access the devices and sessions (for example, the IP address of the device and login information). Each session configuration is based on a default iTest session type (such as Telnet, Web, SNMP, and so on). Third-party providers can supply other session types. You use the Topology editor to define a topology document: all of the physical devices, cards and interfaces on the devices, links between devices, and session configurations defined for devices.

When you associate a topology with a test case, then all of the devices in the topology are available to start sessions in the test case. To run a test case on a different set of physical devices (that is, a different topology), you update the test case to refer to a different topology document.

You will probably not spend too much time in the Topology editor—it is primarily a configuration and a documentation tool.
Let us click **Build a topology** to open the **topology editor**. You do not need to follow along at this time and it will be clearer when we get to the topology module later in the course. Let’s create a topology document, Call it **demo**. As soon as you create a topology and click **Finish**, it opens up the **Topology editor** with supporting views that I need to work on other aspects of the topology. For example, the **Messages view** lists all issues with devices and sessions in the topology. We will talk more about the functionality of the **Palette view**, **Properties view**, and **Error log view** in the Topology module.

As you notice, iTest creates TBML-format files (with file extension **.tbml**)

- You can open an iTest topology document in any TBML-compliant editor
- The iTest Topology editor can open, edit, and save any TBML-compliant file

**Test Case editor**

Let us click the **Home icon** to get back to the Home page of activities perspective.

Let me click Develop a Test Case. The Test Case editor opens. To demonstrate, let’s pick a pre-existing test case under **cbt_project_answers > test_cases > Module4_Test Case Development**.

A different set of views opens. On the left, there is a list of **different tasks** that are required to create the automated test case. On the right, you see the **Test Case editor**.

As you noticed, editors are typically displayed in a tabbed window in the editor area.
Tip: Double-click the tab to maximize any editor. Double-click again to minimize it.

Whenever you open an iTest editor, iTest adds a special menu to the main menu bar. For example, whenever the Test Case editor is active, the Test Case menu appears in the menu bar. The options that appear in the menu vary depending on the editor page in use.

Most of iTest's editors and views include context (right-click) menus for common operations (most toolbar tools appear in the context menus).

For example, in the Test Case editor, there are two menus:

To insert an item (for example, a variable), select the item to replace or place the cursor at the appropriate location and right-click:
To modify a step (skip it, wrap it inside a loop or comment, apply an analysis rule, and so on), select the step and right-click a cell:
Editors **differ** from views in that you can typically **change** the contents of the file in an **editor**. For example, in the Test Case editor, you add and edit steps.

- Any number of editors can be open at once, but only one can be active at a time.
- The items in the main menu bar and main toolbar apply to the active editor.
- Tabs display the names of the documents that are currently open for editing (circled in the example).
- An asterisk * in the tab indicates unsaved changes.
- If there are more editors than can be displayed, the select editor widget appears. The number indicates the number of editors that are not displayed. Click the widget to select an editor from the list.
You can **minimize** the **editor area** by clicking the **Minimize** button.

Click the **editor area icon** to bring back the Editor view back.

Click **Reset Layout** to get back to the default arrangement of views and editors for the current perspective.

Let us go back to the **Home page**. Let us show you an example of how to create a text editor. Go to **File > New > Other**. Notice here that you can drill down to the folders and find a **text file**. In this example, I will type text and the list displays **Untitled Text File**. I will select this and click **Finish**.
Select a wizard

Creates an empty untitled text file

Wizards:

- tex

- General
  - Untitled Text File
Notice here that there is a new tab. Type **Hello World**. This is simply a **text editor**.

As you see, there is a star on the that indicates that something has changed that I have not save. Click **File > select ‘Save as’**

What it shows me is the snapshot of my workspace. I can go ahead and drill into my project. I will save it at the root level of my project and I can give it the name ‘demo_text_file’ and select ok.

**Now you can see the name has changed and tool tip tells me where it has been saved.** I can drill down to the file here under the manage workspace in the iTest explorer view.
That was an overview of the Activities perspective, the Editor view, and the iTest Explorer view.

Let us look at the other perspectives that are available to us. Let’s go to **Windows > Open Perspective > Other**.
As you can see, **iTest Activities** is the default perspective that is opened when we first launch iTest. As you can see by the names of others perspectives, they are optimized for the tasks that you will perform. We will talk about these in the advanced training modules.

All this being said, it is absolutely does not mean that when you are developing test case, you have to be in the test case **development perspective**. It’s just Fanfare's best design as to the arrangement of views you might want to have open for various activities.

Let's click **Windows > Open perspective > Others > iTest Development Perspective**. A shortcut button now appears on the menu bar. You see the views are different now.
The **Favorites view** and the **iTest Explorer view** appear on the left. The **Welcome page** appears in the Editor area on the right. The **Response view** also appears.

These are the views that you will use extensively while developing test cases.

The buttons that appear along the top are names of perspectives that you have used. Click 🔄 to switch to a perspective that does not yet appear here.
Let us select the iTest **Execution perspective**

As you can see the editor is on the left side now. There are a couple new views like **Execution view**, **Test Reports view**, and the **Response view**.
Once you open the perspective, a shortcut button appears on the menu bar to enable you to open a perspective in one click. To close a shortcut button, right-click it and select Close.

Let us close the buttons for **iTest Development perspective** and **iTest Execution perspective**.

Let us go back to the Activities page by clicking the **iTest Activities button**.

Just because a view is not present in your perspective, does not mean that you cannot open it. You can open any view by going to **Windows > Show View > Others** to see the complete list of available views.
Let us suppose I want to open the Test Reports view that we saw in the Execution perspective, I select Test Reports from the list of view or I can pick any from these or drill from the menu items.

Or you can simply type in the filter and get the view you are looking for.

Double-click and now the Test Reports view has been opened.

Let us click the Reset Layout button to get back to the default configuration for this perspective.
During the course, you will be developing the iTest assets under my_project. At the end of the training session, if you want to share it with your team and send it back to Fanfare, do as follows -

1. Rename my_project.

2. Select File > Rename and change the name to training_project. The reason you want to change the name to training_project because my_project is default on all new workspaces of iTest. Therefore if you were to give it to a colleagues, he starts a new workspace and already has a my_project in his workspace and then it makes much more difficult to import as you cannot have two projects of the same name and you got to go ahead and change the name and it becomes a big hassle.

3. Select File > Export

4. Select Archive file. Click Next. Your To Archive Field probably will be blank.

5. What you would want to do is select the training_project project here and by selecting cbt_project, it will select everything underneath.

6. To archive the file, click Browse. Select Desktop and call it training_project.zip.

7. Click Save. Click Finish. Now you take that zip file and mail it to colleague, put it on the flash drive and put it up on the company share and one of my colleagues can import it.

The best practice is not to use the name ‘my_project’ for the iTest project especially when you are sharing the assets with the other people.

Lab

Experiment with Activities Perspective, Preferences, and Views to gain familiarity with the iTest user interface.